status.ping64.net
Dashboard

Some systems are experiencing issues.

game-ryz-08
1 week ago —
Fixed

Fixed

1 week ago —

The server has been replaced. Everything is back online.

Investigating

1 week ago —

The server won't turn on again. An engineer is on his way to replace the server.

1 week ago —

This server is offline. We are checking the server

Incident UUID 2b6e78ab-0202-46ad-b9f7-e3dd945d12be